Issue
Some users have reported that files downloaded via the Tacho5Safe device are not uploading to TachoSafe Web when using the mobile application on Android devices.
Cause
A new Android version was recently released, and the older version of the TachoSafe mobile application is no longer compatible with it. As a result, the file transfer from the Tacho5Safe device to the cloud (TachoSafe Web) fails.
Solution
We have released a new version of the TachoSafe mobile application that is fully compatible with the latest Android updates.
? What You Need to Do:
All Android users who use the Tacho5Safe device to download driver card and tachograph data must update the mobile application (https://play.google.com/store/apps/details?id=com.svt.tachosafe.tacho5afe&hl=en&pli=1) to the latest version.
- Open the Google Play Store on your Android phone or tablet. 
- Search for "TachoSafe". 
- Tap "Update" (or "Install" if not already downloaded). 
- Once updated, reconnect your Tacho5Safe and resume your normal workflow. 
